Pulp-cli-0.23.1 not compatible with pulp.squeezer:0.0.14

Hello guys :lemon:,
the lastest pulp-cli version (pulp-cli-0.23.1) it’s not compatible with the latest pulp3 squeezer module (pulp.squeezer:0.0.14).

It returns the following error when invoking the playbook:
ImportError: Installed 'pulp-glue' version '0.23.1' is not in '>=0.20.0,<0.22.0'

Is there already an open issue to fix this?

Thank you!

1 Like

Thank you for reassuring that squeezer is in actual use.
I however can not make any useful promise that this will be fixed soon. Maybe bumping the version requirement in squeezer would just work, but who knows.
My usual approach to this is to use different virtual environments for ansible and cli. How do you install these tools? Is using pipx for the cli an option?

1 Like

Thank you for the reply!
Yes, pinning the version is definitely a viable option, even if not one of my preferred ones.
Is there a way I can stay updated with this topic?
Should I open an issue on the github repository or is it already taken care in your workflows?

1 Like

You can definitely write an issue with squeezer. There is no automated dependency management yet.

1 Like

Version 0.0.15 is released it is compatible with pulp-glue 0.23 now.