Hi Pulp 3 Ansible Installer users,
In order to more quickly deliver new features and supported use cases, we are considering dropping support for older, seldom used ones.
One issue that has arisen lately is with upgrading from Pulp prior to 3.8, when there was a dependency change. This only pertains to when you are installing from RPMs (“packages”), not from pip (the default).
I am proposing us no longer testing, and supporting upgrading from RPMs prior to 3.8. (packages mode support was always unofficial anyway)
Packages mode users on Pulp prior to 3.8 would upgrade to Pulp 3.14, then to 3.16 (or whatever the latest version is). They would download and run pulp_installer 3.14, then download & run the latest pulp_installer.
Please let us know if there are any objections.
Development is being done here.