Http code 502 "Bad Gateway" when trying to upload a 2Gigs file to pulp

When i try to upload a file over 1Gigs, I get a bad gateway. I can see in the journalctl via “journalctl -xeu docker-compose@pulp.service” that there is a “WORKER TIMEOUT” error, however either via or, I’m not able to get rid of the error, even tho the “dynaconf list” command shows my updated TIMEOUT via WORKER_TTL variable in
Expected outcome:
Upload the file to pulp
Pulpcore version:
Pulp plugins installed and their versions:
“component”: “rpm”,
“version”: “3.16.2”
“component”: “python”,
“version”: “3.6.0”
“component”: “maven”,
“version”: “0.3.2”
“component”: “file”,
“version”: “1.10.1”
“component”: “deb”,
“version”: “2.16.0”
“component”: “container”,
“version”: “2.10.0”
“component”: “certguard”,
“version”: “1.5.2”
“component”: “ansible”,
“version”: “0.11.1”
Operating system - distribution and version:
CentOS Linux 8

Other relevant data:

I’m using pulp in a docker container, the same found in “pulp in one container”.
I’ve added “client_max_body_size 4G;” to my nginx conf

There is an api to upload files in chunks. Would that serve your usecase?

I’ve been trying to upload via chunks, still get http 502.

I would just like to change the gunicorn timeout

Did you break down the file into smaller chunks?
Have you tried using the cli? pulp artifact upload --file <>

I got it working with the API, it was a mistake on my part
Thanks a lot

1 Like

If it’s not too embarrassing, would you mind summing up the mistake and the solution here?

Default gunicorn worker timeout is set to 90 seconds, it can be bumped in case chunked upload does not help.

Actually, we set it to 90 in our installer and operator, but @Joel_Toula seems to be using the single container, I’m bumping the timeout now:

1 Like