Ansible-installer: CONTENT_PATH_PREFIX handling broken

Hi All,

I stumbled across an issue which I am not sure how to describe in a Github issue, so I would like to gather some feedback first.

After a fresh install using the ansible installer, the /etc/pulp/ file contains the following line:
CONTENT_PATH_PREFIX = ‘/pulp/content’

However the default in pulpcore/app/ has a trailing slash:
CONTENT_PATH_PREFIX = “/pulp/content/”

Without the slash the pulp/content url does not work and neither does any distribution url. If I add a slash (or comment the line in the /etc/pulp/ file), it works as expected.

I think the problem may have been introduced by this commit:

CONTENT_PATH_PREFIX option reflected in installer.

Can someone please check this and tell me if the description above is clear enough for an issue in the ansible-installer Github project?


Hi Rolf, the description of the issue is pretty clear so just feel free to open an issue as you have described it.
Folks on the installer team will take it from there.

This problem was reported to pulpocre - I transferred the issue to pulp_installer, you can find it here: